技術関係メモ

古いバージョンが増えてエラーになる

何度か gcloud app deploy を繰り返していると、旧版が溜まって以下のエラーが出てくる。

ERROR: (gcloud.app.deploy) INVALID_ARGUMENT: Your app may not have more than 15 versions. Please delete one of the existing versions before trying to create a new version.

古いバージョンの削除をすれば良い。

現在のバージョン表示は

gcloud app versions list

これで表示されるリストから、削除対象バージョンを見て、

gcloud app versions delete <削除するバージョン番号>

とする。バージョン番号は空白で区切って複数列挙して良い。(ALLとかあるといいな)

ただ、またそのうち溜まってくるし、古いのは消えてくれて良いんだが。 そこらへんの設定はそのうち調べるかも。


トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS